Fax Delivery Delays
Incident Report for FluentStream
Resolved
This incident has been resolved.
Posted Feb 28, 2024 - 20:21 MST
Monitoring
This issue has been resolved for new faxes. Faxes sent previously are being processed and will be sent out over the next few hours. We will continue to monitor and update when all faxes have been delivered.
Posted Feb 28, 2024 - 12:46 MST
Investigating
Inbound faxes are being delayed in delivery. They are not lost and will be delivered once this issue is resolved.
Posted Feb 28, 2024 - 11:55 MST
This incident affected: Fax.