Outbound eFax service degraded performance
Incident Report for FluentStream
Resolved
This issue has been resolved.

We apologize for the inconvenience and hope you have a great afternoon!
Posted Jul 26, 2023 - 15:14 MDT
Monitoring
We have implemented a fix and are monitoring the status to ensure the issue is resolved.

If you continue to experience issues, please reach out to our support team.
Posted Jul 26, 2023 - 14:52 MDT
Investigating
Our engineering team is investigating issues causing degraded performance of outbound fax services. At this time there is no impact to inbound fax services.

Thank you for your patience while we investigate this issue. We will provide additional updates soon.
Posted Jul 26, 2023 - 14:41 MDT
This incident affected: Fax.